Mastercard credits failing for specific merchant accounts
Incident Report for Clearhaus
Resolved
In collaboration with Mastercard we are investigating and exploring the options for cleaning up the remaining inconsistencies. Fortunately only very few merchants are impacted, so further communication will happen directly with the affected merchants; they should expect an update no later than 2023-06-19T16:00:00Z. Therefore, we mark this incident as resolved here.

We have run extra checks to confirm that the fix of inconsistencies for the impacted Mastercard credits from 2023-06-07T08:00:00Z till 2023-06-09T15:00:00Z is successful.

We are deeply sorry about the inconvenience this incident has caused to partners, merchants and cardholders. We strive to do our best so we will surely use the learnings we have had over the last week to improve our systems to help avoid similar consequences in the future.
Posted Jun 16, 2023 - 09:55 UTC
Update
We can positively confirm that the inconsistency has been fixed for the impacted Mastercard credits from 2023-06-07T08:00:00Z till 2023-06-09T15:00:00Z whereas the inconsistency could not be resolved for the transactions in the beginning of the interval (from 2023-06-06T19:00:00Z till 2023-06-07T08:00:00Z).

We are further investigating the remaining inconsistencies and will again be working with Mastercard to resolve this.

Please expect an update on the resolution of the remaining inconsistencies no later than 2023-06-16T10:00:00Z.

Still, Mastercard credits for merchant accounts with MCC 7800, 7801, 7802, 7994, 7995 or 9406 created since processing was resumed Monday are working without issues.
Posted Jun 15, 2023 - 09:41 UTC
Update
We have been working with Mastercard (and have also in parallel run tests) to resolve the inconsistency for the impacted Mastercard credit transactions from 2023-06-06T19:00:00Z till 2023-06-09T15:00:00Z. Preparations for a final solution are happening today, and the results should be available to us tomorrow after a nightly run at Mastercard. Thus, please expect an update on the resolution of the inconsistency no later than 2023-06-15T10:00:00Z.

We have been following the status of Mastercard credits for merchant accounts with MCC 7800, 7801, 7802, 7994, 7995 or 9406 that have been processed since processing of these transactions was resumed Monday, and are happy to report that we see no errors or inconsistencies.
Posted Jun 14, 2023 - 14:23 UTC
Monitoring
We can confirm that our solution was successful and are thus resuming processing of the impacted Mastercard credit transactions.

Please notice that we are still researching how to resolve the inconsistency of approved credits processed from 2023-06-06T19:00:00Z till 2023-06-09T15:00:00Z. Please expect an update on this no later than 2023-06-14T16:00:00Z.
Posted Jun 12, 2023 - 14:23 UTC
Update
The solution is developed in testing, reviewed and tested, and will undergo testing for production readiness. If everything goes as planned, we will run production tests through Mastercard systems Sunday 2023-06-11, and will need to wait for the result till Monday 2023-06-12. No later than 2023-06-12T16:00:00Z will we provide an update regarding our confidence in the solution. If we are confident that our solution is correct, we will resume processing together with the update, otherwise we will most likely need to postpone processing of the impacted Mastercard transactions for another 24 hours.

Thus, expect the next update no later than 2023-06-12T16:00:00Z.
Posted Jun 10, 2023 - 22:13 UTC
Update
We have been looking into this issue throughout the day and will continue to do so over the weekend. A solution for the impacted transactions is under development and has been partially submitted for internal review. The solution is currently being tested. Progress will be slightly slower over the weekend, but we are working on resuming processing of the impacted Mastercard credit transactions as soon as possible.

You can expect the next update before 2023-06-11T00:00:00Z.
Posted Jun 09, 2023 - 22:31 UTC
Identified
We can confirm that this incident is relevant only for Mastercard credits on merchant accounts with MCC 7800, 7801, 7802, 7994, 7995 or 9406. Impacted transactions are currently being actively declined from our end with status code 50000 (Clearhaus error).

The focus is on finding a solution to resume processing, and we are actively working to achieve this. The time frame for a solution is unfortunately not yet known. You can expect an update before midnight UTC.

After processing has resumed we will detail and communicate a plan for resolving the inconsistency of approved credits processed from 2023-06-06T19:00:00Z till 2023-06-09T15:00:00Z. We will explore all options to most effectively (and conveniently to you) handle such inconsistencies. At this stage, we are not yet able to fully investigate the state of these transactions in Mastercard systems. Further updates also in this regard will be posted here as soon as we have them.

The impact of the inconsistency is that an approved credit transaction for an account with above-listed MCCs appears as successful to the partner/merchant but may appear as failed to the cardholder. Please be aware of this when handling cases from cardholders.
Posted Jun 09, 2023 - 14:55 UTC
Investigating
We are noticing problems processing Mastercard credits for specific merchant accounts, namely those with MCC 7800, 7801, 7802, 7994, 7995 or 9406.
Early investigation shows that such transactions since 2023-06-06T19:00:00Z have failed even though our systems returned with status code 20000 (approved). Further investigation will be ongoing in the following hours.

All other transaction processing is not impacted.
Posted Jun 09, 2023 - 12:25 UTC
This incident affected: Payment Processing APIs (Gateway API (gateway.clearhaus.com)).