Mastercard credits failing

Incident Report for Clearhaus

Resolved

Since 2026-08-12 00:05 CEST, approval rate of Mastercard Credits are back to normal.

We are still working with the upstream provider to investigate the core issue, and ensure continued operations.

Regular authorizations and all other transaction types remain unaffected.
Posted Aug 12, 2026 - 03:32 UTC

Identified

We have now confirmed with our upstream provider that all non-EUR Credits are currently being rejected by Mastercard, due to a configuration change between Clearhaus, upstream provider and Mastercard.

Our upstream provider are working on a rollback, and believe to be able to complete this during the night.
Posted Aug 11, 2026 - 14:15 UTC

Investigating

Since 2026-08-07 00:00 CEST, we’ve seen a rise in rejections of Credit transactions by Mastercard.

Credit transactions using EUR as currency are not affected. We are reaching out to our upstream provider and will post another update once we have more information.

Regular authorizations and all other transaction types are unaffected.
Posted Aug 11, 2026 - 13:24 UTC
This incident affected: Payment Processing APIs (Gateway API (gateway.clearhaus.com)).