Google Pay transaction failures

Incident Report for Clearhaus

Postmortem

What happened?

A configuration change caused Google Pay transactions to fail. The change was made to clean up configuration inconsistencies between environments. Google Pay had an implicit dependency on one of these configurations. Before moving traffic to a new deployment, we always run automated test transactions. However, Google Pay is not tested automatically but only per need, as it is a convoluted payment method and difficult to automate. Since this deployment did not include any changes to Google Pay and was not expected to affect it, no additional effort was made to test Google Pay.

Why were we slow to detect it?

Google Pay has significantly less traffic than other payment methods so it hits below our alerting threshold, and because of this we were slow to notice the issue.

Preventive actions

  • We have reviewed the remaining configuration for similar implicit dependencies and found none.
  • We have improved our alerting (see below).

Improved alerting

We have improved our alerting to catch failures affecting a small share of traffic. To avoid a significant number of false positives, we’ve done thorough analysis and backtesting to create advanced alerts that check to confirm that errors don't only happen on individual merchant accounts or for individual issuers. This allows us to be alerted per payment method — even for smaller ones like Google Pay — but also per transaction type — even for smaller ones like credits. With these new alerts in place we would have been alerted to the outage within, at most, 15 minutes.

Posted Sep 01, 2026 - 09:42 UTC

Resolved

On 2026-08-06 between 13:00 and 16:56 UTC, all Google Pay transactions failed with status code 40000, "Google Pay input error, no valid signature of intermediate key". No other payment methods, including Apple Pay and regular card transactions, were affected.

We are improving our alerting in this area to prevent future regressions.
Posted Aug 06, 2026 - 01:00 UTC