dashboard.clearhaus.com, apply.clearhaus.com: Invitations and password resets not working
Incident Report for Clearhaus
Resolved
This incident has been resolved.
Posted 8 months ago. Nov 08, 2017 - 13:13 UTC
Monitoring
All systems should be operational again.
Posted 8 months ago. Nov 08, 2017 - 12:07 UTC
Identified
Due to service provider issues, invitations and password resets for dashboard and apply are affected. Member listings in the dashboard are also affected.

Please notice that login to both dashboard and apply is unaffected; also, transaction processing is unaffected.

We will provide updates as appropriate.
Posted 8 months ago. Nov 08, 2017 - 11:03 UTC