Mastercard 3DSv2 connectivity issues
Incident Report for Clearhaus
Resolved
The service has been stable since last update.

We have received confirmation from Mastercard that they had an issue on their end and that the issue has been resolved.
Posted Nov 25, 2020 - 17:47 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 25, 2020 - 15:40 UTC
Monitoring
We notice that Mastercard is again accepting connections and 3-D Secure version 2 is again functional.
Posted Nov 25, 2020 - 15:39 UTC
Identified
Initial investigation indicates that the connectivity error happens because Mastercard’s directory server is not accepting our client certificate for mutual TLS. We are continuing our investigation, trying out ideas for mitigation, and working with Mastercard to resolve the issue.

Notice that this incident is not affecting transaction processing (acquiring), 3-D Secure version 1 (MPI), nor 3-D Secure version 2 for Visa.
Posted Nov 25, 2020 - 15:18 UTC
Update
We are continuing to investigate this issue.
Posted Nov 25, 2020 - 14:44 UTC
Investigating
Around 2020-11-25T14:23:35 UTC, we began seeing issues connecting to the Mastercard 3DSv2 (Identity Check) Directory Server.

We are currently investigating and have reached out to Mastercard.
Posted Nov 25, 2020 - 14:42 UTC
This incident affected: Payment Processing APIs (3-D Secure Server API (service.3dsecure.io)).