Payouts in DKK delayed
Incident Report for Clearhaus
Resolved
Merchants respond that the payouts was received this morning; this should hold for all merchants. If you still have not receive your payout, please reach out: https://www.clearhaus.com/contact
Posted about 1 year ago. Oct 28, 2016 - 09:23 UTC
Monitoring
The bank processing our payouts in DKK have not processed the transactions in a timely manner. The payments should be visible for merchants receiving payouts in DKK at most one day later than usual. Please contact us if you have questions: https://www.clearhaus.com/contact/
Posted about 1 year ago. Oct 27, 2016 - 13:14 UTC