Dashboard home page long load times
Incident Report for Clearhaus
Resolved
This issue is now resolved.
Posted Jun 14, 2016 - 08:53 UTC
Monitoring
We are experiencing long query times with a service provider, causing the Dashboard home page to have long load times.

Only the Dashboard home page is affected. All the other sections are operational.
Posted Jun 14, 2016 - 07:15 UTC