Delayed transactions
Incident Report for Clearhaus
Resolved
This incident has been resolved.
Posted Jul 09, 2016 - 08:23 UTC
Monitoring
This morning there was a delay in making transactions available in our merchant dashboard.

This outage did not affect our ability to process transactions coming in from merchants.
Posted Jul 09, 2016 - 07:18 UTC