Delayed transactions
Incident Report for Clearhaus
Resolved
We have finished servicing our databases and have processed all queued transaction which are now available in the dashboard.
Posted Jul 15, 2016 - 16:49 UTC
Monitoring
We are currently servicing our database servers, as a consequence transactions are delayed in appearing in the dashboard.

This does not affect our ability to process transactions from merchants.
Posted Jul 15, 2016 - 13:21 UTC