Switching between accounts
Incident Report for Clearhaus
Resolved
This incident has been resolved.
Posted Jul 08, 2016 - 10:25 UTC
Investigating
Currently there is an issue with changing between accounts in the merchant dashboard. This only applies to merchants that have more than one account.

This incident do not affect our ability to process transactions.
Posted Jul 08, 2016 - 09:56 UTC